Technical instructions to join Victar webinar

Dear attendees of Victar webinars,

 

For a smooth experience, please, make sure that your system conforms with the following requirements.

System Requirements: PC-based attendees required: Windows® 7/8, Vista, XP or 2003 Server OR Mac®-based attendees required: Mac OS® X 10.6 or newer

Mobile attendees required: iPhone®, iPad®, Android™ phone or Android™ tablet

iPhone®, iPad® and Android™ apps to attend Spreed Online Meeting:

Check in itunes our Spreed App for iPhone®: https://itunes.apple.com/app/spreed/id327211373?mt=8

 

We look forward to communicating with you,

Victar.org